I have been working with constraints in Swift for iOS, and most of the naming conventions/documentation make things quite self explanatory, but one thing that has recently confused me is two pairs of the NSLayoutXAxisAnchor class:
leadingAnchor, leftAnchor
along with
trailingAnchor, rightAnchor
When I have set constraints programmatically in my iOS app, I have found that I can use these totally interchangeably. If I use leadingAnchor, run the app and observe the behavior, and then use leftAnchor, run the app and observe the behavior, it functions exactly the same.
I checked out the documentation from developer.apple.com, and the results are even exactly the same (ignoring the difference in names). For example comparing the leadingAnchor and leftAnchor:
"Use this anchor to create constraints with the view’s leading edge.
You can only combine this anchor with a subset of the
NSLayoutXAxisAnchor anchors. You can combine a leadingAnchor with
another leadingAnchor, a trailingAnchor, or a centerXAnchor. For more
information, see NSLayoutAnchor Class Reference."
compare to:
"Use this anchor to create constraints with the view’s left edge. You
can only combine this anchor with a subset of the NSLayoutXAxisAnchor
anchors. You can combine a leftAnchor with another leftAnchor, a
rightAnchor, or a centerXAnchor. For more information, see
NSLayoutAnchor Class Reference."
Does anyone know if there is any intended difference between these properties?
See Question&Answers more detail:
os 与恶龙缠斗过久,自身亦成为恶龙;凝视深渊过久,深渊将回以凝视…