请选择 进入手机版 | 继续访问电脑版
  • 设为首页
  • 点击收藏
  • 手机版
    手机扫一扫访问
    迪恩网络手机版
  • 关注官方公众号
    微信扫一扫关注
    迪恩网络公众号

ios - 放弃对 iOS 4 的支持

[复制链接]
菜鸟教程小白 发表于 2022-12-13 17:09:42 | 显示全部楼层 |阅读模式 打印 上一主题 下一主题

我有一个目前在 iOS4-6 上运行良好的应用程序。但是,我想使用仅支持 5 及更高版本的较新库。删除操作系统版本的后果是什么? iOS4上的人如何备份他们的应用程序?我应该告诉他们从 iTunes 备份 IPA 文件吗?我知道在某些情况下,我需要旧 iOS 版本的文件但无法取回文件。

如果你不得不放弃一个 iOS 版本,你会怎么做?



Best Answer-推荐答案


如果您想放弃对 iOS 4 的支持,后果可能是多方面的,而且肯定会有一些用户陷入您所说的“需要一个无法取回的文件”的情况。

无论如何,我认为告诉您的用户备份应用程序数据和 IPA 文件是一个很好的策略(您可能会设计另一种策略,就像 @benzado 建议的那样,但您提议的策略适用于当然,即使在用户决定通过 iTunes 更新应用程序的情况下)以降低风险。

我唯一不知道的是你将如何告诉他们这样做。也许通过一个中间版本说:这是iOS4的最后一个?不确定。

另一方面,我不确定您是否真的需要放弃对 iOS4 的支持。

看看this post用于一般方法。

如果您只是想添加一个新框架(存在于 iOS5/6 而不是 iOS4),只需弱链接这些框架,然后有条件地包含这些框架的 header 即可。

说你想支持 Twitter;那么你有条件地包含标题:

#if defined(__IPHONE_5_0) && __IPHONE_OS_VERSION_MAX_ALLOWED >= __IPHONE_5_0
#import <Twitter/Twitter.h>
#import <Accounts/Accounts.h>
#endif

并且有条件地保护 Twitter 方法的使用:

Class tweeterClass = NSClassFromString(@"TWTweetComposeViewController");
if (tweeterClass != nil && [tweeterClass respondsToSelectorselector(canSendTweet)]) {
   ...
}

(此代码只会在iOS5/6上执行)。

至于弱链接,转到您的目标选项,显示构建阶段,您可以在“与框架的链接”下添加新框架;只需确保您选择右侧的“可选”选项(见图)。

enter image description here

关于ios - 放弃对 iOS 4 的支持,我们在Stack Overflow上找到一个类似的问题: https://stackoverflow.com/questions/12963169/

回复

使用道具 举报

懒得打字嘛,点击右侧快捷回复 【右侧内容,后台自定义】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注0

粉丝0

帖子830918

发布主题
阅读排行 更多
广告位

扫描微信二维码

查看手机版网站

随时了解更新最新资讯

139-2527-9053

在线客服(服务时间 9:00~18:00)

在线QQ客服
地址:深圳市南山区西丽大学城创智工业园
电邮:jeky_zhao#qq.com
移动电话:139-2527-9053

Powered by 互联科技 X3.4© 2001-2213 极客世界.|Sitemap